网络连接 属性 高级 WMI损坏 15

网络连接 属性 高级 里出现这样的情况??请看http://pe.images22.51img1.com/6000/jianguo6477/e5580b7462ecb90f61e9628ac9d3d1cd.jpg 里的图片 。。。怎样解决??
不能还原系统也不要重装系统,可不可以直接修复?
我有更好的答案
邀请更新
2008-11-15 最佳答案
Windows不能显示此连接的属性,Windows Management Instrumentation(Windows管理体系结构组件WMI)信息可能损坏。要更正此问题,请使用系统还原将Windows还原到一个较早的时间点。 

可以断言 你是windows SP1系统,因为那个故障只出现在SP1系统中,是由于SP系统不稳定,并且和现在的软件冲突(最可能冲突的就是杀毒软件或是播放类软件),由于SP1系统是比较老的操作系统,所以会出现冲突,建议,重新做下系统,最好升级到SP2系统或更高的系统。

当然若是还用SP1系统,以后若是再装什么软件 还会出现类似的情况。
————————————————————————————
补充回答:
方法一:
重装一下TCP/IP协议试试。
右键点击网络连接并选择Properties 项,然后系统会列出连接协议列表。现在点击Install按钮并选择Protocol,然后点击Add。之后点击Have Disk并输入C:\Windows\inf(假设C:\Windows是你的Windows系统路径)。从列表中选择Internet Protocol (TCP/IP)项,并点击OK。重新启动电脑。
——————————————————————————————————
方法二:
@echo on
cd /d c:\temp
if not exist %windir%\system32\wbem goto TryInstall
cd /d %windir%\system32\wbem
net stop winmgmt
winmgmt /kill
if exist Rep_bak rd Rep_bak /s /q
rename Repository Rep_bak
for %%i in (*.dll) do RegSvr32 -s %%i
for %%i in (*.exe) do call :FixSrv %%i
for %%i in (*.mof,*.mfl) do Mofcomp %%i
net start winmgmt
goto End

:FixSrv
if /I (%1) == (wbemcntl.exe) goto SkipSrv
if /I (%1) == (wbemtest.exe) goto SkipSrv
if /I (%1) == (mofcomp.exe) goto SkipSrv
%1 /RegServer

:SkipSrv
goto End

:TryInstall
if not exist wmicore.exe goto End
wmicore /s
net start winmgmt
:End

将上述代码复制保存为.bat后缀的文件,然后在安全模式下运行,完毕后再重启即OK了!
————————————————————————————————
方法三:
上网搜一个批处理文件(WMI补丁)根据你的XP系统版本 搜索对应的WMI补丁 然后 安全模式下运行。
————————————————————————————————
个人建议:最好升级系统到SP2吧,SP1系统漏洞实在是太多了- -!

为您推荐:

广告

您可能关注的内容

×

类别

我们会通过消息、邮箱等方式尽快将举报结果通知您。

说明

0/200

提交
取消